Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst USMT Win7 zu Win 10 kurioses Migration Problem mit JavaScript

Mitglied: Muetze

Muetze (Level 1) - Jetzt verbinden

13.03.2019 um 13:27 Uhr, 290 Aufrufe, 11 Kommentare, 2 Danke

Wir nutzen eine Cloudanwendung, die auch für den Internet Explorer Edge freigeben ist und auch tadellos damit funktionier. Wenn ein Benutzer von seinen alten Windows 7 Rechner zu seinen neuen Windows 10 Rechner mit den Tools USMT (scanstate und loadstate) migriert wird, läuft der Prozess tadellos ohne Problem durch. Alle Daten & Einstellungen werden übernommen.

Nach der Migration funktioniert die Cloudanwendung nicht mehr richtig. Es kommt im Bereich JavaScript zu einen Ausnahme Fehler.

Das Beispiel Skript geht dann auch nicht mehr.

https://www.w3schools.com/jsref/tryit.asp?filename=tryjsref_tolocaledate ...

Mit diesem Fehler lässt sich die Anwendung nicht bedienen. Der alte Internet Explorer IE 11 hat das Problem nicht, ist aber für die Anwendung zu langsam und auch nicht supportet.

Nach der Migration ist es auch egal welcher Benutzer sich anmeldet. Es funktioniert bei keinem mehr. Deswegen gehe ich davon aus das es ein Computer Einstellungsproblem ist.

Wenn man ein Systemwiederherstellungspunkt vor der Migration angelegt hat, kann man das Verhalten zurückdrehen.

Was habe ich schon probiert, um das Problem zu lösen.

  • Edge Einstellungen alle zurückgesetzt
  • Datum / Ländereinstellung verglichen
  • Windows System State Analyzer, um rauszufinden was geändert wird. Leider ohne Erfolg da es einfach bei den Vergleichen abstürzt.
  • Process Monitor – das ist aber wie die Nadel im Heuhaufen suchen
  • Windows 10 OEM Rechner aus der Verpackung, hat auch das gleiche Problem
  • Alle Gruppenrichtlinien deaktiviert.
  • Offline Migration

Kennt einer das Problem oder hat vielleicht noch ein paar Lösungsansätze? Kann man bei der Migration von USMT „This Computer“ ausschließen?

Ich bin für jeden Tipp dankbar.

Liebe Gruße
Stephan
Mitglied: ashnod
13.03.2019 um 13:35 Uhr
Moin ...


öhm, so richtig verstehe ich dein Problem nicht wirklich, hast du mal na der installierten Java-Version geschaut oder ob die überhaupt installiert ist?

VG
Bitte warten ..
Mitglied: departure69
13.03.2019, aktualisiert um 14:04 Uhr
@Muetze:

Hallo.

Dein Beispiel-Skript funktioniert hier mit dem Edge-Browser einwandfrei. Und der hat bei uns keinerlei vom ausgelieferten Standard abweichende, besondere Einstellungen, durch keine GPO beeinflusst, gar nichts, weil wir den IE11 als Standard verwenden. Der Edge ist hier also jungfräulich unter W10 Pro x64, neuester Build von heute, 13.03.2019 inkl. des CU von letzter Nacht (Patch-Day). Also W10 Pro x64 1809 17763.348.

Die Migration, so, wie Ihr sie durchführt, ist ja anscheinend gar nicht das Problem, wenn ein frisch ausgepackter, jungfräulicher OEM-Rechner bei Euch dabei genauso Probleme macht.

Bleibt eigentlich nur ein Problem in Eurer Umgebung, in Eurem Netz, in Eurer Domäne. GPOs im Einsatz (also insbesondere solche, die den Edge irgendwie beeinflussen)?

Firewalls blockieren manchmal Javaskript-Code.


Viele Grüße

von

departure69
Bitte warten ..
Mitglied: Muetze
13.03.2019 um 14:52 Uhr
Es geht um JavaScript und nicht um Java.
Bitte warten ..
Mitglied: Muetze
13.03.2019 um 14:57 Uhr
Das Problem tritt ja auch nur auf wenn der Rechner mit loadstate ein Profil migriert bekommt. Dort wird irgendwas verändert das dann dazu führt das JavaScript mit Edge und dieses Funktion ein problem hat. Sobald die Migration abgeschlossen ist im CMD Fenster und dann Edge geöffnet wird geht es nicht mehr. Es ist nichtmal ein neustart / abmelden oder sonstigen nötig. Es geht einfach dannacht nicht mehr.
Bitte warten ..
Mitglied: departure69
13.03.2019, aktualisiert um 16:19 Uhr
Ah ja, verstehe, es geht darum, daß das mit einem migrierten Benutzerprofil nicht mehr geht. Ich wußte nicht, was "Tools USMT (scanstate und loadstate)" bedeutet.

Tja, dann stimmt wohl mit eben diesem Tool bzw. dem Migrationsprozeß etwas nicht. Immerhin kommen die Profile, wenn ich es richtig verstanden habe, von Windows-7-Systemen (und W7 hatte ja noch keinen Edge). Offenbar interpretiert das Migrationstool irgendwas aus einem W7-Profil unter 10 anders, und dies wirkt sich, warum auch immer, beim Edge negativ aus.

Ich würde den Herstellersupport des Tools "Tools USMT (scanstate und loadstate)" anschreiben.


Viele Grüße

von

departure69
Bitte warten ..
Mitglied: Muetze
14.03.2019 um 08:13 Uhr
Genau das "irgendwas" gilt es zu finden. Das Tool USMT gehört zu Windows Assessment and Deployment Kit (Windows ADK). Ich habe bei MS keine Support Adresse finden die genau dafür zuständig. Meine Erfahrungen mit der MS Hotline sind nicht gerade positiv. Sie stahlen nicht gerade viel Fachkompetenz aus. Bei so was Spezialen wird es bestimmt nicht besser.

Windows komplette reparieren behebt den Fehler zwar, dauert aber auch fast 2 Stunden. Dabei wird eine neue Installation durchgeführt und dann die Benutzerdaten migriert.
Bitte warten ..
Mitglied: departure69
LÖSUNG 14.03.2019 um 12:22 Uhr
Zitat von Muetze:

Genau das "irgendwas" gilt es zu finden. Das Tool USMT gehört zu Windows Assessment and Deployment Kit (Windows ADK). Ich habe bei MS keine Support Adresse finden die genau dafür zuständig. Meine Erfahrungen mit der MS Hotline sind nicht gerade positiv. Sie stahlen nicht gerade viel Fachkompetenz aus. Bei so was Spezialen wird es bestimmt nicht besser.


Du/Ihr wirst/werdet vermutlich ohnehin nicht den dazu nötigen Supportvertrag mit Microsoft haben. Oft kann man sich hierzu aber an größere Systemhäuser wenden, die solche Verträge mit Microsoft haben und solche Probleme aufgrund dessen an Microsoft eskalieren können.

Windows komplette reparieren behebt den Fehler zwar, dauert aber auch fast 2 Stunden. Dabei wird eine neue Installation durchgeführt und dann die Benutzerdaten migriert.

Die Benutzerprofile manuell neu einzurichten (denn es geht ja scheinbar nur um diese) geht nicht schneller, als eine Neuinstallation des ganzen Systems und dann nochmals das komische Tool zu benutzen?

Viele Grüße

von

departure69
Bitte warten ..
Mitglied: Muetze
14.03.2019 um 13:16 Uhr
Ich habe nun das Problem gefunden. Ich habe auf den System vor und nach dem Import ein Snapshot der Registrie gemacht. Dort ist mir dann folgende Reg-Key aufgefallen der hinzugefügt wurde.

01.
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Time Zones\Armenian Standard Time]
02.
"Display"="(GMT+04:00) Eriwan"
03.
"Dlt"="Armenische Sommerzeit"
04.
"Std"="Armenische Normalzeit"
05.
"TZI"=hex:10,ff,ff,ff,00,00,00,00,c4,ff,ff,ff,00,00,00,00,00,00,00,00,00,00,00,\
06.
  00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00
Wenn man diesen entfernt, funktioniert die Anwendung sofort.

Damit ist das Problem gelöst
Viele Grüße
Mütze
Bitte warten ..
Mitglied: departure69
14.03.2019 um 14:05 Uhr
Hattest Du das Tool, das Ihr verwendet habt, von der Microsoft-Webseite in Armenien heruntergeladen?
Bitte warten ..
Mitglied: Muetze
14.03.2019 um 16:18 Uhr
Ich glaube das in Windows 7 Armenien vorhanden war und im Windows 10 nicht mehr. Die Time Zones in Windows 10 haben auch mehr Werte als dieses.
Bitte warten ..
Mitglied: departure69
14.03.2019 um 17:10 Uhr
Ich hatte meine Frage eher als Scherz gemeint, aber wenn das wirklich der Unterschied 7 -> 10 ist, dann könnte das natürlich der Grund sein.

Freut mich, daß Du jetzt weißt, woran's liegt/lag.


Viele Grüße
Bitte warten ..
Ähnliche Inhalte
Windows 10
Windows 10 Migration
gelöst Frage von OrkansonWindows 1018 Kommentare

Hallo zusammen, ich wollte mal Tipps sammeln. Wir haben vor dieses Jahr rund 40 PCs auf Windows 10 umzustellen. ...

Windows 10
Win 10 Uhrzeit
Frage von talaihanWindows 101 Kommentar

Hallo, gibt es bei Windows 10 eine Möglichkeit die Uhrzeit auf einer Analogen Uhr anzeigen zu lassen als auf ...

Windows 10

Win 10 installation auf alten Win7 HW mit Amazon product Key

gelöst Frage von VizmanWindows 102 Kommentare

hallo gemeinde ich habe einen 3 jahre alten HP Laptop der bisher nur mit Win7 genutzt wurde. er wird ...

Windows Server

Migration iis7 zu iis 10

Frage von HanutaWindows Server8 Kommentare

Hallo Zusammen, habe die Migration nach folgendem Schema durchprobiert: IIS7 to IIS10 Das hat wie in der Anleitung mit ...

Neue Wissensbeiträge
Administrator.de Feedback
Was als Noob hier mal gesagt werden musste
Information von th30ther vor 1 TagAdministrator.de Feedback2 Kommentare

Moinsen wertes Forum, ich möchte mich an dieser Stelle mal beim Forum generell und bei aqui speziell bedanken! Ich ...

Windows 10
Windows 10 Mai 2019 Update (Version 1903) ist da
Information von kgborn vor 1 TagWindows 104 Kommentare

Nur ein kurzer Infosplitter: Microsoft hat die Nacht (21. Mai 2019) das Funktionsupdate auf Windows 10 Version 1903 freigegeben. ...

E-Mail

Newsletter: Unread News - IT News in Byte Länge

Tipp von franktaylor vor 1 TagE-Mail11 Kommentare

Hallo, würde gerne auf einen Newsletter hinweisen, den ich heute per Zufall gefunden und mit euch gerne teilen möchte: ...

Outlook & Mail

Outlook 2016 stürzt ab, wenn man ein (at)- Zeichen im Text einer neuen E-Mail schreibt

Tipp von Enriqe vor 2 TagenOutlook & Mail4 Kommentare

Bei uns in der Firma häuften sich die Fälle, bei denen sich Outlook kommentarlos verabschiedet, wenn man ein - ...

Heiß diskutierte Inhalte
Hyper-V
Novell virtualisieren
Frage von spoboeHyper-V20 Kommentare

Hallo zusammen, ich habe absolut keine Ahnung von Novell, aber wir haben hier ein ganz altes Schätzchen (vermutlich Novell ...

Windows Server
Ungewollte IP Änderung am DC sorgt für Probleme
Frage von thomas-99Windows Server19 Kommentare

Hallo Zusammen, wir haben ein kleines Netz mit 5 verschiedenen VMs (DC, AD, Fileserver, Exchange, TK Anlage - alle ...

Windows Netzwerk
Netzlaufwerk: einfache Liste der täglich gelöschten, geänderten+neuen Files
gelöst Frage von mylightWindows Netzwerk17 Kommentare

wir haben Windows Clients, das zentrale Teamlaufwerk liegt auf einem Netzwerkserver (ca. 100Gb, 10.000 Verzeichnisse, 180.000Dateien), auf die Konsole ...

Netzwerkmanagement
Gateprotect Firewall - Internetseiten werden teilw. nicht geladen
Frage von KivasFNetzwerkmanagement16 Kommentare

Morgen Zusammen, ich habe ein Problem mit einer Gateprotect Firewall welches mir echt Kopfschmerzen bereitet. Die Firewall hängt an ...