Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWünsch Dir wasWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Kurioses Problem mit Fritzbox und debian-Squid3

Mitglied: Wern2000

Wern2000 (Level 1) - Jetzt verbinden

25.06.2020, aktualisiert 09:13 Uhr, 301 Aufrufe, 7 Kommentare

Hallo,

ich hab hier ein ein paar Tagen ein sehr komisches Internetproblem in zusammenspiel mit meinem Debian-Squid-Proxy und der Fritzbox.
Bis jetzt hat alles ohne Probleme funktioniert aber sein ein paar Tagen hmm...

zum eigentlichen Problem:
Diverse Internetseiten lassen sich nicht mehr aufrufen. Man muss ewig auf eine Fehlermeldung warten

Firefox
Amazon -> gesicherte Verbindung fehlgeschlagen
h30434.www3.hp.com -> gesicherte Verbindung fehlgeschlagen
paypal -> gesicherte Verbindung fehlgeschlagen
flickr -> läd und irgendwann kleines fenster "ups da ist was fehlgeschlagen"
google -> funktioniert
ebay -> funktioniert
yahoo -> funktioniert

Opera

Amazon -> funktioniert
paypal -> funktioniert
ebay -> Webseite konnte nicht erreicht werden
flickr -> Webseite konnte nicht erreicht werden
yahoo -> funktioniert

Das Interessante ist, dass wenn ich ohne Proxy in's Internet gehe, sind alle Seiten auf jedem Browser problemlos zu öffnen.
Der Squid3 läuft weitgehend in der grundkonfiguration (schon mehrere Jahre so. Ist eine VM auf einem Windows 2019 Server)
Der Diskcache, objektgröße wurde vergrößert und eine txt datei mit blocked domains wird geladen.
hab schon Diskcache neu aufbauen lassen -> keine besserung
proxy neu gestartet -> keine besserung
Wenn z.B amazon aufgerufen wird sieht das acces.log so aus

1593066183.437 20053 192.168.0.101 TCP_TUNNEL/200 222 CONNECT www.amazon.de:443 - HIER_DIRECT/104.108.44.223 -
1593066185.256 20050 192.168.0.101 TCP_TUNNEL/200 222 CONNECT www.amazon.de:443 - HIER_DIRECT/104.108.44.223 -
1593066190.210 20050 192.168.0.101 TCP_TUNNEL/200 222 CONNECT h30434.www3.hp.com:443 - HIER_DIRECT/184.30.223.39 -
1593066199.675 171425 192.168.0.101 TCP_TUNNEL/200 5503 CONNECT fonts.googleapis.com:443 - HIER_DIRECT/216.58.207.170 -
1593066201.499 20049 192.168.0.101 TCP_TUNNEL/200 222 CONNECT www.amazon.de:443 - HIER_DIRECT/104.108.44.223 -
1593066203.510 20054 192.168.0.101 TCP_TUNNEL/200 222 CONNECT www.amazon.de:443 - HIER_DIRECT/104.108.44.223 -
1593066205.317 20055 192.168.0.101 TCP_TUNNEL/200 222 CONNECT www.amazon.de:443 - HIER_DIRECT/104.108.44.223 -
1593066210.288 20076 192.168.0.101 TCP_TUNNEL/200 222 CONNECT h30434.www3.hp.com:443 - HIER_DIRECT/184.30.223.39 -
1593066213.362 20046 192.168.0.101 TCP_TUNNEL/200 222 CONNECT www.amazon.de:443 - HIER_DIRECT/104.108.44.223 -
1593066221.642 20141 192.168.0.101 TCP_TUNNEL/200 222 CONNECT www.amazon.de:443 - HIER_DIRECT/104.108.44.223 -
1593066223.577 20050 192.168.0.101 TCP_TUNNEL/200 222 CONNECT www.amazon.de:443 - HIER_DIRECT/104.108.44.223 -
1593066225.380 20061 192.168.0.101 TCP_TUNNEL/200 222 CONNECT www.amazon.de:443 - HIER_DIRECT/104.108.44.223 -


jetzt kommt das aberwitzige:
Wenn ich der Fritzbox 7490 sage das die internetverbindung neu aufgebaut werden soll (kein reboot oder dsl-sync neu aufbauen) funktioniert der Squid wieder ohne probleme. Alle Internetseiten lassen sich wie gewohnt ratz fatz öffnen.
Die Fritzbox mach auch Täglich um ca 3:45 Uhr eine zwangstrennung.

Hat da jemand einen tip für mich was das sein könnte?

grüsse
Mitglied: NordicMike
25.06.2020 um 09:37 Uhr
Klingt, als ob die Anzahl der offenen Ports die Fritzbox überlastet, durch das Trennen schliesst du alle offenen Verbindungen und alles geht wieder. Überprüfe im Squid die offenen 443 Ports.
Bitte warten ..
Mitglied: Wern2000
25.06.2020 um 09:47 Uhr
aktuell nichts besonderes.
aber müsten die nicht alle geschlossen werden wenn ich den squid neu starte? Denn auch ein neustart des Squid oder ein reboot der VM brachte keine besserung.
Alle Internetseiten gingen ohne Proxy problemlos auf.
Bitte warten ..
Mitglied: NordicMike
26.06.2020 um 09:02 Uhr
Ich weiss nicht wie lange es dauert, bis die Fritzbox das verwirft, wenn der Squid neu startet. Ob sie es überhaupt verwirft, weil, sie hängt ja. Da habe ich zu wenig Erfahrungen damit.
Bitte warten ..
Mitglied: Wern2000
29.06.2020, aktualisiert um 05:41 Uhr
hatte eben den Fehler wieder.
etliche Internetseiten gingen über den Proxy nicht auf. Proxy deaktiviert Seiten gingen. Proxy wieder aktiviert Seiten gingen nicht mehr.
Fritbox neu verbinden lassen und alles geht wieder
Bitte warten ..
Mitglied: NordicMike
29.06.2020 um 10:30 Uhr
Aha, also ist das Limit tatsächlich in der Fritzbox erreicht, jedoch nur für ein Gerät, den Proxy - als einziger CLient. Er gibt also eine maximale Anzahl offener Ports pro Client.

Wenn du den Proxy deaktivierst, bleiben die Ports in der Fritzbox offen. Die anderen Geräte öffnen dann neue Ports. Wenn du den Proxy wieder aktivierst, sind die alten Ports immer noch offen und es geht nichts mehr.

Also müsstest du jetzt in zwei Richtungen recherchieren:
1) Kann man der Fritzbox diese Limitierung deaktivieren?
2) Kann der Proxy bei nichtgebrauch die Ports wieder schließen z.B. nach einem gewissen Timeout

zu 2)
Man muss überlegen, ob es Ports sind, die von Clients wirklich verwendet werden oder ob sie übrig geblieben sind und nicht mehr verwendet werden. Dafür gibt es Befehle zur analyse in Linux (im Squid).
Eine überlegung wäre es die Ports nach einer gewissen inaktivität vom Squid schliessen zu lassen.
Bitte warten ..
Mitglied: Wern2000
29.06.2020 um 12:18 Uhr
Werde da ein bisschen nachforschen

Aber wieso tritt der Fehler erst seit kurzem auf?
Die firmware der Fritzbox ist vom 09.08.2019
Die squid konfig hat sich ebenfalls seit mehrereren jahren nicht geändert.
Bitte warten ..
Mitglied: NordicMike
30.06.2020, aktualisiert um 04:49 Uhr
Vielleicht steigt ja eure Netzwerklast, vielleicht saut auch irgendein einzelner Client herum und macht ein Port nach dem anderen auf. Vielleicht macht sich ein Trojaner breit. Da hilft nur den Traffic zu analysieren. Zum Glück gibt es dafür ja genügend Befehle unter Linux.
Bitte warten ..
Ähnliche Inhalte
Internet
Telekom kurios
gelöst Frage von BosnigelInternet20 Kommentare

Moin! Ich hab hier mal folgende Begebenheit: AVM 7590 mit Firmware 6.98 (oder so) an Telekom 100 Mbit Anschluß. ...

Linux
Squid3 Proxy diverse Ports freischalten
Frage von crackhawkLinux3 Kommentare

Hallo Zusammen! Ich habe mir auf meinem Debian 8.8 Server Zuhause einen Squid3 Proxy-Server aufgesetzt. Dieser funktioniert soweit auch ...

LAN, WAN, Wireless

IPv6 Konfiguration FritzBox, Debian-Server mit CNAME

gelöst Frage von BierkistenschlepperLAN, WAN, Wireless6 Kommentare

Guten Morgen, da mein neuer Anschluss eine IPv6 Adresse enthält, wollte ich das endlich einmal probieren. Ich habe auf ...

Utilities

Squid3 ACLs greifen nicht

gelöst Frage von Windows10GegnerUtilities2 Kommentare

Hallo, ich will gerade im squid3 unter Ubuntu 18.04 eine Blocklist einrichten. Es sollen einfach bestimmte Domainnamen blockiert werden. ...

Neue Wissensbeiträge
LAN, WAN, Wireless
Sophos Central Wireless v2.3.0-6 massive Probleme
Information von Voiper vor 21 StundenLAN, WAN, Wireless

Hallo Zusammen, wenn Ihr Sophos Central nutzt und die neuen APX Accesspoints im Einsatz habt, vermeidet das Update der ...

Off Topic
Wuebra - tech-flare
Information von tech-flare vor 1 TagOff Topic3 Kommentare

Servus, Nein ihr seid mich nicht los Aus Wuebra wird tech-flare. Schöne Restwoche :)

Ausbildung
Crashkurs in Computertools - das fehlende Semester
Information von NetzwerkDude vor 2 TagenAusbildung

Moin, habe eigentlich was anderes gesucht, aber zufällig diesen MIT Kurs gefunden: Sind 11 Lektionen je 1 Stunde, als ...

Windows Netzwerk
Unsichtbare DHCP Leases finden und löschen
Anleitung von binBash86 vor 2 TagenWindows Netzwerk

Wir hatten häufiger das Problem, dass ein Windows DHCP Server scheinbar keine Leases mehr frei hat, wenn man aber ...

Heiß diskutierte Inhalte
Netzwerkgrundlagen
Router mit fremden zusätzlichen Accesspoint verbinden
Frage von skorpion-inkaNetzwerkgrundlagen42 Kommentare

Hallo!! Ich habe folgende Problem mit einem Netzwerk (siehe Bild). Ich habe eine Fritzbox an der eine Wechselrichter mit ...

LAN, WAN, Wireless
Patchkabel vs Verlegekabel kuerzen und crimpen
gelöst Frage von WashingtonLAN, WAN, Wireless34 Kommentare

Hi, wir haben einen miesen Rat angenommen und fertig konfektionierte 50m Kabel erworben, diese verlegt und gesehen das diese ...

SAN, NAS, DAS
Server -VS- NAS ?
Frage von Mann-000SAN, NAS, DAS24 Kommentare

Hallo zusammen, ich habe einige Seite durchgelesen (viel altes Zeug von 2011 etc. gefunden) und frage mich immer noch, ...

Hyper-V
VHDX löschen (Datei wird verwendet)
gelöst Frage von 72-dpijunkieHyper-V21 Kommentare

Guten Morgen zusammen, ich habe ein Problemchen und weiß nicht mehr weiter. Vielleicht kann mir jemand von euch helfen? ...