Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Frage zu Cisco Catalyst 2960

Mitglied: White-Rabbit2

White-Rabbit2 (Level 1) - Jetzt verbinden

10.09.2019, aktualisiert 17:53 Uhr, 261 Aufrufe, 7 Kommentare

Hallo.
Wir haben einen "alten" Cisco Catalyst 2960 (genauer 2960S-24PS-L V04) bekommen, mit dem ich mich nun herumschlage. Ich habe folgendes per CLI versucht, um ihn so zu konfigurieren, dass er mit den anderen Switches spricht ... .das klappt aber nur mäßig gut:

01.
interface Gi1/0/3
02.
(switchport trunk encapsulation dot1q )  (Befehl wird nicht akzeptiert -- offenbar gibt es nur diesen Modus)
03.
switchport mode trunk 
04.
switchport trunk native vlan 12
05.
switchport trunk allowed vlan 10 60

Ich hatte gehofft, dass auf diese Weise VLAN.12 untagged und die beiden VLANs 10 und 60 tagged an Port 3 anliegen. Leider bekommt jedoch ein Gerät an Port 3 keine IP-Adresse.
Als Zuleitung zum Switch habe ich Port 2 konfiguriert und -so die Hoffnung- alle VLANs auf die Leitung gelegt. VLAN.2 ist dabei das Management-VLAN für die Switche

01.
interface Gi1/0/2
02.
switchport mode trunk 
03.
switchport trunk native vlan 2
04.
switchport trunk allowed vlan all
Zudem ist dem Switch auf VLAN.2 eine IP zugewiesen. Ich kann mich auch problemlos am Switch anmelden; ein ping in VLAN.2 klappt auch. Leider finde ich weit und breit nur Beispiele, wo zwar unterschiedliche VLANs auf dem Switch verwendet , dann aber immer nur access-Ports verwendet werden... daher nochmal hier die Frage: kann der Switch das nicht oder wie muss die Konfiguration lauten? Sieht jemand den Fehler?

Also nochmal zusammenfassend:
Ich möchte
  • auf den Ports 1 und 2 alle VLANs, wobei dort VLAN.2 untagged anliegt.
  • auf den Ports 3-24 das VLAN.12 untagged und die beiden VLANs 10 und 60 tagged haben.

(Leider kann ich momentan kein "show running-config" rüberschicken ... bin nicht vor Ort.)


Danke.
Mitglied: aqui
LÖSUNG 10.09.2019, aktualisiert um 19:10 Uhr
Zuerstmal heisst das Teil "Catalyst". Für peinliche Vertipper in der Überschrift gibts den "Bearbeiten" Button
Zurück zum Thema...
die keinerlei Verbindung zum Host oder den anderen PC´s im Netzwerk hat
Das sollte er auch wenn er mit einer Default Konfig daherkommt.
Ich hatte gehofft, dass auf diese Weise VLAN.12 untagged und die beiden VLANs 10 und 60 tagged an Port 3 anliegen.
Deine Hoffnung war schon richtig und auch die Konfig dazu. Allerdings möchte der Catalyst auch das du ihm das Native VLAN auch in der Allow Liste mitgibst damit es funktioniert.
Richtig ist also:
!
switchport mode trunk
switchport trunk native vlan 12
switchport trunk allowed vlan 10 12 60
!

Alternativ kannst du auch wenn du die erlaubten VLANs nicht explizit angeben willst den Schrotschuss "switchport trunk allowed vlan all" verwenden. Der inkludiert dann auch dein VLAN 12, hat aber den Nachteil das dann ggf. auch VLANs dort auf dem Trunk übertragen wird die du da nicht haben willst un den Port mit ungewolltem Traffic belastet.
Und ja...in den neueren IOS Versionen gibt es das Kommando "switchport trunk encapsulation dot1q" nicht mehr bzw. man hat es eliminiert, da der proprietäre Tagging Mode der Cisco Anfangszeit nirgendwo mehr genutzt wird. Es reicht also ein schlichtes "switchport mode trunk" um den Port zu einem Tagged Uplink zu machen.
Als Zuleitung zum Switch habe ich Port 2 konfiguriert und
Jepp, das ist syntaktisch genau richtig gemacht !
Sieht jemand den Fehler?
Nein, alles richtig gemacht !
Was du allerdings oben mit etwas verschwurbelten "Leider finde ich weit und breit nur Beispiele, wo zwar unterschiedliche VLANs auf dem Switch verwendet , dann aber immer nur access-Ports verwendet werden... " genau meinst ist etwas unverständlich. Vielleicht kannst du das nochmal etwas präzisieren.
Zu deinen Forderungen:
1.)
Die Port Konfig sieht dann für 1 und 2 so aus:
!
interface Gi 1/0/1
description Uplink xyz
switchport mode trunk
switchport trunk native vlan 2
switchport trunk allowed vlan all
!

2.)
Bei den Ports 3 bis 24 sieht es dann so aus:
!
interface Gi 1/0/3
description Uplink zyx
switchport mode trunk
switchport trunk native vlan 12
switchport trunk allowed vlan 10, 12, 60
!

Fertisch !

Zum Schluss noch ein warnendes Wort !
Bedenke das die Cisco Catalyst Switches ein proprietäres Per VLAN Spanning Tree Verfahren benutzen !
Solltest du sie mit anderen (Billig)Switches koppeln die kein PVSTP+ supporten sondern nur ein einfaches Single Span Verfahren MUSST du das entsprechend berücksichtigen !
Tust du das nicht kommt es zum Spanning Tree Chaos und unkontrolliertem Verhalten im Netz da diese STP Verfahren bzw. Protokolle NICHT miteinander kompatibel sind !
Hast du solche heterogene STP Umgebung dann hast du letztlich nur 2 Optionen:
  • Spanning Tree entweder beim Cisco oder den anderen Switches ganz ausschalten und "durchzuschleifen".
  • Das gemeinsame STP Protokoll MSTP nutzen, was so gut wie alle Switches weltweit supporten.
Letzteres ist das technisch Beste weil du so eine konsistente Spanning Tree Umgebung hast. Option 1 hat das nicht und es kann sektorweise zu Loops im Netz kommen.
Wie eine saubere MSTP Konfig bei den Ciscos aussieht zeigt dir dieser Thread:
https://www.administrator.de/frage/spanning-tree-modus-migration-pvst-ms ...

Und nochwas...
Sollten deine angeschlossenen "anderen" Switches kein VTP supporten was so gut wie sicher ist (Cisco proprietär !) dann solltest du VTP und auch die Cisco Trunk Autoconfig immer abschalten in der Konfig mit "switchport nonegotiate" bzw. VTP global mit "vtp mode off".
Das sähe dann alles zusammen so aus:
!
vtp mode off
!
interface Gi 1/0/1
description Uplink Port 1 und 2
switchport nonegotiate
switchport mode trunk
switchport trunk native vlan 2
switchport trunk allowed vlan all
!
interface Gi 1/0/3
description Uplink Port 3 bis 24
switchport nonegotiate
switchport mode trunk
switchport trunk native vlan 12
switchport trunk allowed vlan 10, 12, 60
!
interface vlan 2
description Management Interface
ip address 172.16.1.1 255.255.255.0
!
Bitte warten ..
Mitglied: White-Rabbit2
10.09.2019 um 18:00 Uhr
Hallo.

Super -- danke.
Das werde ich so ausprobieren.
Die anderen Switche sind SG300er und ein SG350X -- also alles ebenfalls Cisco. Die sollten sich dann ootb vertragen & verstehen, oder?

Was du allerdings oben mit etwas verschwurbelten " ..." meinst ...
Ich hatte nach "basic example configuration catalyst 2960" gesucht und nicht das gefunden, was ich erhofft hatte.

Die Überschrift ist korrigiert ... den typo hatte ich übersehen...
Bitte warten ..
Mitglied: aqui
LÖSUNG 10.09.2019, aktualisiert um 19:14 Uhr
Die anderen Switche sind SG300er und ein SG350X -- also alles ebenfalls Cisco.
Die supporten, obwohl auch Cisco, kein PVSTP+ und nur Single Span ! Also musst du hier den MSTP Weg gehen am besten. Ist ja auch kein Problem und ein 3 Zeiler in der Konfig fixt das im Handumdrehen:
!
spanning-tree mode mst
spanning-tree extend system-id
!
spanning-tree mst configuration
name weisser_hase
revision 1
!
spanning-tree mst 0 priority 8192
!

Damit macht der Switch dann MSTP und alle VLANs sind in der Default Instance 0 und der Switch ist der Root Switch (Spanning Tree Priority !).
Ggf. kannst du ein Layer 2 Balancing über 2 unterschiedliche Instances mit verschiedener Priority machen in die du deine VLANs verteilst. Das macht aber einzig nur dann Sinn wenn du ein Ausfall sicheres bzw. redundantes Netzwerk Design verwendest und 2 redundante Core Switches betreibst wie es z.B. hier zu sehen ist:

stackdesign - Klicke auf das Bild, um es zu vergrößern

Hast du das nicht macht das Splitting in Instances keinen Sinn und kannst du weglassen.

Als Root Switch sollte man nur den (oder die) Core Switch setzen was dein Catalyst ja vermutlich dann auch ist ?!
Die SG Modelle sehen dann so aus im MSTP Setup:
mstp - Klicke auf das Bild, um es zu vergrößern
Ist der Root Switch (Layer 3 Core) aber einer der SG Modelle dann bleibt der Catalyst auf dem Default und der SG Rootswitch bekommt dann die 8192 als STP Priority !!
Mit einem show spanning-tree mst auf dem Catalysten kannst du sehen ob er die MSTP Nachbarn alle erkannt hat und das MSTP sauber rennt.

VTP können die SG Modelle auch nicht, folglich also auf den Catalysten dann abschalten wie oben beschrieben.
Bitte warten ..
Mitglied: White-Rabbit2
10.09.2019 um 18:48 Uhr
Vielen Dank für die ausführlichen Erläuterungen! Ist nicht selbstverständlich ...
Bitte warten ..
Mitglied: aqui
10.09.2019, aktualisiert um 19:03 Uhr
In diesem Forum schon...
Nochwas...
Denk dran das du auch das Management IP Interface deiner SG Modelle ins VLAN 2 hievst wo auch der Catalyst und vermutlich deine anderen Management IPs liegen !

mgmt - Klicke auf das Bild, um es zu vergrößern
Hast du aber vermutlich selber schon auf dem Radar.

Viel Erfolg beim Umsetzen. Kannst ja mal ein Feedback geben obs geklappt hat. Ansonsten dann...
https://administrator.de/faq/32
Bitte warten ..
Mitglied: White-Rabbit2
12.09.2019 um 22:14 Uhr
Hi.
Kurze Rückmeldung: Es hat geklappt ... der Switch ist wieder einsatzbereit und die Ports 3-24 laufen via POE und vergeben auch die richtigen IPs.
Der Catalyst soll übrigens nicht der Root Switch ... das ist ein SG350X, der als Layer3 Router fungiert. Da ist die Priorität auch entsprechend eingestellt.

Ich hätte ja noch ganz gerne so ein Event, dass der Switch abends die Ports deaktiviert, damit da nicht völlig unnötigerweise 24/7 Energie verbraten wird. Leider bin ich nicht sicher, ob der 2960 das schon kann -- neulich hatte ich eine Anleitung, die nicht funktioniert hatte. Wie stehst du zu der harten Methode: Zeitschaltuhr direkt an den Switch? Machen die das mit oder ist das kontraproduktiv?

Schöne Grüße!
Bitte warten ..
Mitglied: aqui
13.09.2019 um 10:17 Uhr
Kurze Rückmeldung: Es hat geklappt ..
Wie zu erwarten wenn man es richtig macht !
das ist ein SG350X, der als Layer3 Router fungiert. Da ist die Priorität auch entsprechend eingestellt.
Perfekt !
So ein L3 Grund Design sieht dann immer so aus:
https://www.administrator.de/forum/verständnissproblem-routing-sg30 ...
so ein Event, dass der Switch abends die Ports deaktiviert, damit da nicht völlig unnötigerweise 24/7 Energie verbraten wird.
Müsste eigentlich.... Das macht man mit dem kron Kommando. So könnte sowas aussehen:
!
kron occurrence shut at 23:00 recurring
policy-list shut_poe
!
kron policy-list shut_poe
cli shut int gig1/0/10
!

kron sollte ein IOS Switch eigentlich auch supporten. Die Cisco Doku darüber hat alle Details:
https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/cns/configuration/15-s ...

Es gibt zig Lösungen dafür wenn du danach googelst:
https://community.cisco.com/t5/routing/how-to-automatically-shutdown-poe ...
https://glennmatthys.wordpress.com/2014/08/24/turning-off-power-over-eth ...
Bitte warten ..
Ähnliche Inhalte
Switche und Hubs

Cisco Catalyst 2960-l VTP Verständnisfrage

gelöst Frage von 138064Switche und Hubs7 Kommentare

Hallo zusammen, Eine kurze Verständnisfrage. Ich habe vier Catalyst 2960-l-16PS und muss 10 Vlans im 4000er Bereich anlegen. Durch ...

Switche und Hubs

Cisco Catalyst 6506 Lüfter reduzieren?

Frage von Hedwig5Switche und Hubs4 Kommentare

Hallo Administratoren! Wir setzen einen Cisco Catalyst 6506 mit HighSpeed Fan Tray ein. Die Lüfter "pusten" (laut Ton) immer ...

LAN, WAN, Wireless

Cisco Catalyst Konsolenport besser absichern

gelöst Frage von nullModemLAN, WAN, Wireless16 Kommentare

Hallo zusammen, brauche mein eure Hilfe. Es geht um Cisco Catalyst 2960x Switche. Ich habe jetzt dem SSH Zugang ...

LAN, WAN, Wireless

Neue Cisco Catalyst-Serie 9000

Information von KuemmelLAN, WAN, Wireless

Hatte schon jemand so ein Ding in den Händen und kann was dazu sagen? Was meint ihr dazu? Gruß ...

Neue Wissensbeiträge
Voice over IP

Telekom Umstellung von ISDN Anlagenanschluss auf IP-Telefonie

Erfahrungsbericht von NixVerstehen vor 1 TagVoice over IP6 Kommentare

Hallo zusammen, nachdem nun vor ein paar Tagen die zwangsweise Umstellung von ISDN auf IP-Telefonie problemlos über die Bühne ...

Apple

Apple Special Event vom 10.09.2019: Arcade, TV+, iPad und iPadOS, Watch und iPhone 11

Information von Trontur vor 3 TagenApple2 Kommentare

Hier könnt ihr euch die Keynote von Tim Cook auf dem Apple Special Event vom 10.09.2019 anschauen: September Event ...

LAN, WAN, Wireless

Das RIPE ist quasi endgültig leer was IPv4 angeht

Information von LordGurke vor 10 TagenLAN, WAN, Wireless8 Kommentare

Das RIPE teilt mit, dass sie erwarten, Ende des Jahres keine /22-IPv4-Allocations (1.024 Adressen) mehr vergeben zu können. Dann ...

Verschlüsselung & Zertifikate

Ein besserer Weg zur Delegation of Control für Bitlocker Recoverykeys

Anleitung von DerWoWusste vor 11 TagenVerschlüsselung & Zertifikate

Will man Supportmitarbeitern ermöglichen, Bitlocker-Recoverykeys auszulesen, dann bietet sich eigentlich der Delegation of Control Wizard an. Ich zeige zunächst ...

Heiß diskutierte Inhalte
Router & Routing
Freitagsfrage: Welche Heimrouter habt ihr zuhause?
Frage von Ex0r2k16Router & Routing28 Kommentare

Huhu, Ich habe eine Fritzbox 7490 an nem 100/40 VDSL der Tkom und die kommt langsam in die Jahre. ...

Exchange Server
Exchange 2013 nach Umzug nicht erreichbar
gelöst Frage von dbox3Exchange Server16 Kommentare

Hallo, die Lösung für mein Problem mag einfach sein. Nur stehe ich irgendwie auf dem Schlauch. ich habe einen ...

Switche und Hubs
Hardwareberatung Switch
gelöst Frage von snowflockeSwitche und Hubs12 Kommentare

Hallo, ich bin ganz neu hier also seit gnädig :-) Ich bin seit 5 Jahre in der IT tätig, ...

Voice over IP
Telekom Umstellung von ISDN Anlagenanschluss auf IP-Telefonie
Erfahrungsbericht von NixVerstehenVoice over IP6 Kommentare

Hallo zusammen, nachdem nun vor ein paar Tagen die zwangsweise Umstellung von ISDN auf IP-Telefonie problemlos über die Bühne ...